NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: MPEG Codec on RPI 2 Live TV no audio on 2 Channels

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #1

I installed openelec on my Rpi 2. All is well but after I purchased and installed the MPEG codec I have no sound on two of the OTA TV Channels. Same whether I use the HDHomrerun add-on or add UPNP channels with HDHomerun tuner.
I tried the OSMC install and the Raspbian with Kodi and experienced the same symptoms so problem must be Rpi related.
Any setting or tweeks I can do in openelec to get audio on these two channels.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #2

Update. I installed and configured TVheadend server and client add-ons and the sound has been working for about 30 minutes now. Will let it run and see if all is well.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #3

  • islipfd19
  • islipfd19's Avatar
  • Offline
  • Senior Boarder
  • Posts: 109
  • Thank you received: 12
  • Karma: 2
You need to go into the HDHomerun Addon specific settings to change the sound preferences to the channels that are "missing" audio. Some channels send the audio on different audio channels.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #4

I had been using the UpNp in files to watch. I installed the HDHomerun add-on but could find no options to change audio in config. No sound on channel 2.1 with add-on either.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #5

  • islipfd19
  • islipfd19's Avatar
  • Offline
  • Senior Boarder
  • Posts: 109
  • Thank you received: 12
  • Karma: 2
Which HDHomerun addon version are you using? Does it have a slide out from the right displaying the channel/program info?
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #6

Version 2016.03.24
Yes it has the menu on the right showing available channels
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #7

  • islipfd19
  • islipfd19's Avatar
  • Offline
  • Senior Boarder
  • Posts: 109
  • Thank you received: 12
  • Karma: 2
When you begin to exit that app, a menu appears you can select the video or audio menu to change your options.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #8

That did the trick, thanks. For some crazy reason selecting channel 2 Spanish gave me audio in English.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #9

Still a problem. Every few minutes I lose audio and have to switch audio channels.
TVHeadend still working well but often have to enable server tuner on reboot.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #10

  • islipfd19
  • islipfd19's Avatar
  • Offline
  • Senior Boarder
  • Posts: 109
  • Thank you received: 12
  • Karma: 2
the only suggestion I have then is to look for assistance on the hdhomerun forum for the addon. It's silicondust's addon and someone with better knowledge and experience should be able to help you there. They may be able to look at the diagnostic logs SD gets.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #11

OK will do. Also get the same problem with UpNp also.
The administrator has disabled public write access.

MPEG Codec on RPI 2 Live TV no audio on 2 Channels 1 year 5 months ago #12

I searched the HDHomerun forum and it turns out several people have reported the same problem.
Couldn't find a solution though.
The administrator has disabled public write access.