NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: Making menu sounds work

Making menu sounds work 6 years 1 month ago #1

  • therio
  • therio's Avatar
  • Offline
  • Staff
  • Posts: 2161
  • Thank you received: 185
  • Karma: 78
If you don't have menu sound working by default, the first thing you can do is search the supported hardware section for a possible set-up of an asound.conf file (openelec.tv/forum/41-supported-hardware). But in some cases, your box isn't listed yet and you may need to build an asound.conf file on your own. Here's an easy how-to for it that will essentially work for most boxes:

First download the add-on "Nano" from the OpenELEC repo inside XBMC. This is an useful tool to edit files within an terminal (like SSH). After installation, reboot your box.

After that, you'll need to SSH into your box. We need a log that contains detailed info about the possible output devices. When logged in, type:
aplay -l

This will give a list of audio devices that are available in your box. My log looks like this:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0

As you can see, I have an HDMI and Analog output. This can be different in your box, but it shows the data we want.

If you use a HDMI connection for your output, the line "card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]" is the only thing you need to know. Or, if you want analog, the line containing "Analog" would be it and so on for your options. Also it is possible that there are more than 1 lines with the same output device mentioned (mostly for HDMI). This will come later in this how-to, but you will need to know them all. So you better write them down temporary.

For making an asound.conf file, give the following commands:
nano /storage/.config/asound.conf

This opens an empty screen. Copy the text beneath in it:
pcm.!default {
   type plug
    slave {
      pcm "hw:x,y"
      rate 48000
   }
}

Now take your copied lines from the aplay -l, and change the x and y in the line "pcm "hw:x,y"" with the following info:

change x with the number after "card" (in this example for HDMI, "card 0")
change y with the number after "device" (in this example for HDMI, "device 3")

Press ctrl+x to save it, type yes, enter, enter
Now reboot and see if it works.

If you have more than 1 output devices listed, test all setups like above to find out which works.
For example, you have 3 lines, all telling they are HDMI outputs, but differ in the device number. You first start with the first output device. Save the configuration like above and reboot. Test if you hear menu sounds. If not, open up a SSH connection again and now give the following command:
nano /storage/.config/asound.conf

Edit the card and device number so they match output device 2. Save it, reboot and test. Still not working? Change it again for output device number 3.

If it still doesn't work, make a new topic in the help section and tell us what you did. Also paste the output of the aplay -l log and give us enough details about your box, which build you're using and how you're connecting the audio to the TV / stereo.
A thank you is nice, but a donation is more needed ;)
Thanks in advance!!
Last Edit: 6 years 1 month ago by therio.
The administrator has disabled public write access.
The following user(s) said Thank You: jokster, Whiskey, gsusnl, azazel673

Re: Making menu sounds work 5 years 11 months ago #2

  • ladaowner
  • ladaowner's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Thank you received: 1
  • Karma: 0
Word of caution read the instructions fully, lol. Reboot after loading nano or you get a no permissions error and half an hour of hair pulling.

Watch out as one paypal donation is coming your way this weekend. This distro is much better than the xbmc live CDs that can update due to uxlauncher problems.
Last Edit: 5 years 11 months ago by ladaowner.
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 5 months ago #3

  • MindTooth
  • MindTooth's Avatar
  • Offline
  • Expert Boarder
  • Posts: 409
  • Thank you received: 9
  • Karma: 4
Took a year, but I finally managed to get my sound working :P

Thanks!
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 5 months ago #4

  • therio
  • therio's Avatar
  • Offline
  • Staff
  • Posts: 2161
  • Thank you received: 185
  • Karma: 78
LOL Mind, you just could have PM-ed me, would have saved you a year!
A thank you is nice, but a donation is more needed ;)
Thanks in advance!!
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 5 months ago #5

  • MindTooth
  • MindTooth's Avatar
  • Offline
  • Expert Boarder
  • Posts: 409
  • Thank you received: 9
  • Karma: 4
Haha! :P

It's just that now I took the time to actually follow your guide. Were done it five min or less :)

Thanks, bro!
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 5 months ago #6

  • pete01
  • pete01's Avatar
Thanks therio, this work for me as well, running on ATV using chewitt's latest install tool (beta5) to install openelec!

For anyone who is interested in the exact settings I used they are:

1. Created asound.conf file in /storage/.config/
vi /storage/.config/asound.conf

2. Entered the following into asound.conf:
pcm.!default {
  type plug
  slave {
    pcm "hw:0,3"
  }
}

3. Reboot ATV.


Note: I had to remove the 'rate 48000' line for it work. Also, I had to set Audio device to 'hdmi (ALSA)' in the System -> System -> Audio XBMC menu.
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 4 months ago #7

  • Ayala
  • Ayala's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Karma: 0
I can't get this to work for my acer eve 3700! :( movies are fine but menu it silent.
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 4 months ago #8

  • MindTooth
  • MindTooth's Avatar
  • Offline
  • Expert Boarder
  • Posts: 409
  • Thank you received: 9
  • Karma: 4
The administrator has disabled public write access.

Re: Making menu sounds work 5 years 4 months ago #9

  • Ayala
  • Ayala's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Karma: 0
MindTooth wrote:
think I'll open a new thread as suggested ;)
The administrator has disabled public write access.

Making menu sounds work 3 years 8 months ago #10

  • niehztog
  • niehztog's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
My platfgorm is the Raspberry Pi. When issuing the "aplay -l" command, the console says: "command is not found"
So I am unable to complete this guide as described. Is there a workaround for the raspberry pi?
The administrator has disabled public write access.