NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: The big jitter thread (ION/VDPAU)

The big jitter thread (ION/VDPAU) 6 years 2 months ago #1

  • pseudo7
  • pseudo7's Avatar
  • Offline
  • Junior Boarder
  • Posts: 61
  • Thank you received: 4
  • Karma: 2
Hi all,

I having an issue which seems to be cropping up more frequently (possible because i've noticed it).

When playing videos ocaationally the video with stutter/jitter then continue, when I got back a couple of seconds then play the same section it doesn't jitter.

I managed to get some logs from the box. Most of the time it happens it records an warning of:
WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 31593, consumed: 0

Logs:
On SSD : pastebin.com/E7u4fbhE
On hard drive: pastebin.com/Xh1WNc69 and pastebin.com/8CgfxhaN

The media info of one of the files (though it seems to happen on other files too:
pastebin.com/XeSNm6md

At first I though it may be the hard drive's fault so I copied a film to the internal ssd and it still happened.

Have I set something wrong?

I'm using RC7 but it was present in RC5 and it never used to do it, then it started doing it more.

Any help of this issue would be much appreciated - I love openelec but stumbing on video playing is not good (especially when trying to show it off!)
Last Edit: 6 years 1 month ago by pseudo7. Reason: meant to put RC5 not RC6 - corrected
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #2

  • kaliko
  • kaliko's Avatar
Hi,

I'm having the same problem. I think it is an occasionally/random issue. I have got this stutter independently of the media I played. With DVDs is more difficult to perceive the stutter, but with Blu-ray is really evident.

I'm using openelec under a XS35GT.

Cheers.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #3

  • mauzzz
  • mauzzz's Avatar
  • Offline
  • Junior Boarder
  • Posts: 71
  • Thank you received: 8
  • Karma: 0
Since RC7 my Shuttle will stutter every few minutes. Even with SD quality video. I never had that problem with RC5. For me it is not a network problem; with RC5 a 25 Gb .m2ts file would play flawlessly over LAN.
ASUS Chromebox (celeron), Openelec 5.0.8, Aeon Shednox
Panasonic GT60, Cambridge Audio TV2
Synology 411j
Last Edit: 6 years 1 month ago by mauzzz.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #4

  • pseudo7
  • pseudo7's Avatar
  • Offline
  • Junior Boarder
  • Posts: 61
  • Thank you received: 4
  • Karma: 2
Nice to know it's probably not some hardware breaking.

Anyone know what this actually means:
Decode - avcodec_decode_video didn't consume the full packet
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #5

  • kaliko
  • kaliko's Avatar
Hi pseudo7,

I think we're experiencing a XBMC problem and not an issue on the openelec distro.

I read something about FernetMenta's implementations on an ION2 optimized branch. Unfortunately it seems to still be a first(beta) attempt to optimize vdpau for IONs chips...
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #6

  • rubylaser
  • rubylaser's Avatar
  • Offline
  • Junior Boarder
  • Posts: 79
  • Thank you received: 4
  • Karma: 0
This issue has been around for a while.

I don't think it's FernetMenta's changes as those have been out for a number of months and have worked great for me and others in the past. If anything, using a FernetMenta build might improve your experience.

Besides, I don't believe that those changes have been rolled into RC7, because sraue said that those changes wouldn't be included until they made it into the XBMC trunk. Since those changes aren't included in the Eden builds, there's no reason to think they've been included in the Dharma builds.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #7

  • mauzzz
  • mauzzz's Avatar
  • Offline
  • Junior Boarder
  • Posts: 71
  • Thank you received: 8
  • Karma: 0
I have no idea what is the cause of the stutter. But since RC5 and RC7 have the same XBMC version I would look elsewhere. Maybe the video driver makes the difference. Pure speculation.
ASUS Chromebox (celeron), Openelec 5.0.8, Aeon Shednox
Panasonic GT60, Cambridge Audio TV2
Synology 411j
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #8

  • kaliko
  • kaliko's Avatar
Hi rubylaser,

I have expressed my self wrong.

I don't known if FernetMenta's implementations are or will be included in XBMC. I only read that there is an optimized branch (www.xbmcfreak.nl/en/ion2-optimized-branch/) that works better for ION-systems.

I would like to test the improvements, but for that I have to compile epenelec + XBMC myself. Maybe I'll find the needed time someday.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #9

  • rubylaser
  • rubylaser's Avatar
  • Offline
  • Junior Boarder
  • Posts: 79
  • Thank you received: 4
  • Karma: 0
Okay, thanks for clarifying. Also, as an FYI, you don't have to compile Openelec yourself to test out the Optimizations. Here's a link to compiled versions for ION2 systems.

ION2 Optimized Builds
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #10

  • kaliko
  • kaliko's Avatar
Thank you for the link. I see that the last compiled branch was on 2011.08.17. I would like to try the current openelec version, that now is 1.0. The only alternative we have is to compile the source ourselves.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #11

  • pseudo7
  • pseudo7's Avatar
  • Offline
  • Junior Boarder
  • Posts: 61
  • Thank you received: 4
  • Karma: 2
What has changed in 1.0, i can't find a change list - prob cos i'm being dim!
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #12

  • pseudo7
  • pseudo7's Avatar
  • Offline
  • Junior Boarder
  • Posts: 61
  • Thank you received: 4
  • Karma: 2
Hmm. I've watched two hd films (ones that stuttered the most) using 1.0 and didn't see any stuttering.

Looking good!

Cheers devs!
Last Edit: 6 years 1 month ago by pseudo7.
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #13

  • Bossanova808
  • Bossanova808's Avatar
  • Offline
  • Expert Boarder
  • Posts: 362
  • Thank you received: 10
  • Karma: 7
Can we get word from the devs/others on this - should 1.0 solve most of the stuttering issues?? RC1 is the smoothest for me (Shuttle XS35GT) of 'official' releases, so my main machine is stuck on that. (RC2 to RC5 stutterd a lot). I have not tried post RC5 - was there any work in this area?? Nvidia drivers changes??
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #14

  • Bossanova808
  • Bossanova808's Avatar
  • Offline
  • Expert Boarder
  • Posts: 362
  • Thank you received: 10
  • Karma: 7
Hmm, on 1.0.1 on a Shuttle XS35GT the stuttering is back again...so it's back to RC1 for me...unless someone wants to build a V1+ with the older nvidia drivers and/or the FernetMenta changes incorporated...
The administrator has disabled public write access.

Re: XS35GTV2 - Jittering 6 years 1 month ago #15

  • BreeeZe
  • BreeeZe's Avatar
Having the same issues on Zotac Zbox ND41 :(

Are there any (annoying) issues in RC1 compared to 1.0.1 ?

Installing an ubuntu VM on my mac, see if I can figure out how to build a 1.0.1 with the RC1 driver, as a professional C# developer I should be able to do it ;)
Last Edit: 6 years 1 month ago by BreeeZe.
The administrator has disabled public write access.