NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Second HDD won't mount.

Second HDD won't mount. 4 years 10 months ago #1

  • HartzIV
  • HartzIV's Avatar
Hi,

i've bought a second HDD for my HTPC. It's a 1TB Western Digital Cavia green.
The problem is that it wont appear in the XBMC GUI.

But when i SSH into it i see the sda1 that is new in /dev/.

I tried to mount it but it always says: Invalid Argument.
For example: mount /dev/sda1 /var/media/

The HDD is formatted with NTFS (EXT4 didn't work too).

The Mainboard i use is an ASUS E35M1-M.

Any suggestions?
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #2

  • chewitt
  • chewitt's Avatar
/dev/sdaX will be the boot device on the system, it will not be the USB drive
dmesg | paste
mount | paste
share the URLs
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #3

  • HartzIV
  • HartzIV's Avatar
The HDD is connected via SATA on the mainboard.

When i remove it i only have: sdb, sdb1,sdb2
In the gui it shows me the same. The system is on this device and boots from there.

dmesg= sprunge.us/GgHQ
mount= sprunge.us/TSei
Last Edit: 4 years 10 months ago by HartzIV.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #4

  • ultraman
  • ultraman's Avatar
  • Online
  • Platinum Boarder
  • Posts: 4647
  • Thank you received: 889
  • Karma: 324
also
fdisk -l /dev/sda | paste
ultraman == vpeter
LAMP addon - Linux, Apache, MySQL PHP bundle
Sundtek and HDHomeRun DVB driver addons
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #5

  • HartzIV
  • HartzIV's Avatar
root / # fdisk -l /dev/sda | paste
-sh: fdisk: command not found
You are trying to send an empty document, exiting.

:-/
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #6

  • ultraman
  • ultraman's Avatar
  • Online
  • Platinum Boarder
  • Posts: 4647
  • Thank you received: 889
  • Karma: 324
This should do
parted -l | paste
ultraman == vpeter
LAMP addon - Linux, Apache, MySQL PHP bundle
Sundtek and HDHomeRun DVB driver addons
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #7

  • HartzIV
  • HartzIV's Avatar
sprunge.us/UbGG

sdc is my USB-Harddrive that is already working.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #8

  • ultraman
  • ultraman's Avatar
  • Online
  • Platinum Boarder
  • Posts: 4647
  • Thank you received: 889
  • Karma: 324
As you can see partition on sda disk is not formated. Even partition is short. Use some tutorial how to do that directly on openelec with parted or on any other computer.
Disk /dev/sda: 1000GB
Partition Table: msdos

Number  Start  End    Size   Type     File system  Flags
 1      131kB  125GB  125GB  primary
ultraman == vpeter
LAMP addon - Linux, Apache, MySQL PHP bundle
Sundtek and HDHomeRun DVB driver addons
Last Edit: 4 years 10 months ago by ultraman.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #9

  • HartzIV
  • HartzIV's Avatar
strange... i already formatted it with windows several times :/.

Ok I will try to do it with parted this time.

**************EDIT***************

Mhm i dont get it.

In parted i deleted the partition with rm 1,
then make new with "mkpart primary ntfs 100 999999". When I enter print it shows me the new partition but it has no filesystem.

Am i doing something wrong? Do you have a good tutorial for parted?
Last Edit: 4 years 10 months ago by HartzIV.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #10

  • HartzIV
  • HartzIV's Avatar
I tried to format it now with Easeus Partition Master Home Edition.

It shows me still no filesystem with "parted -l | paste". On my PC the HDD works fine...
Model: ATA WDC WD10EARX-00N (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.3kB 125GB 125GB primary

And it also shows these weird start stop sectors o_O
Last Edit: 4 years 10 months ago by HartzIV.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #11

  • chewitt
  • chewitt's Avatar
the following should erase the drive and create a new partition that fills the drive. If this drive is internal it can be formatted as ext4 instead of NTFS which will result in faster read/write times (we mount NTFS with the NTFS-3G userspace driver which is slower)

First we erase existing bootsectors (nuke existing partitions)
dd if=/dev/zero of=/dev/sda bs=512 count=100
we create a new GPT partition structure on /dev/sda
parted -a optimal /dev/sda mklabel gpt
we add an ext4 partition from 1MB to -1MB from the end of the drive
parted -a optimal /dev/sda mkpart -- primary ext4 1 -1
we add the ext4 filesystem and label the drive as NEWDRIVE
mkfs.ext4 -L NEWDRIVE /dev/sda1
and finally we run a filesystem check; this command automounts the new partition when done
fsck.ext4 /dev/sda1
Last Edit: 4 years 10 months ago by chewitt.
The administrator has disabled public write access.

Re: Second HDD won't mount. 4 years 10 months ago #12

  • HartzIV
  • HartzIV's Avatar
Model: ATA WDC WD10EARX-00N (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  1000GB  1000GB  ext4         primary

it worked perfect!

Thank you very much!
The administrator has disabled public write access.

Re: Second HDD won't mount. 3 years 10 months ago #13

chewitt wrote:
the following should erase the drive and create a new partition that fills the drive. If this drive is internal it can be formatted as ext4 instead of NTFS which will result in faster read/write times (we mount NTFS with the NTFS-3G userspace driver which is slower)

First we erase existing bootsectors (nuke existing partitions)

<code>dd if=/dev/zero of=/dev/sda bs=512 count=100</code>we create a new GPT partition structure on /dev/sda

<code>parted -a optimal /dev/sda mklabel gpt</code>we add an ext4 partition from 1MB to -1MB from the end of the drive

<code>parted -a optimal /dev/sda mkpart -- primary ext4 1 -1</code>we add the ext4 filesystem and label the drive as NEWDRIVE

<code>mkfs.ext4 -L NEWDRIVE /dev/sda1</code>and finally we run a filesystem check; this command automounts the new partition when done

<code>fsck.ext4 /dev/sda1</code>

If I did this for each of my internal drives that I want on xbmc, would it be permanent? So would it persist after reboot?

Thanks
The administrator has disabled public write access.

Re: Second HDD won't mount. 2 years 11 months ago #14

  • Jerome 347
  • Jerome 347's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
Hi @chewitt,
can i follow this procedure to format (ext4) an external 1TB HDD conected to a PI through USB?

My systems are OSX, and i'm struggling to format the drive on them. i thought of gparted, but i'm not confortable with defining permitions and so on, so I guess it would be easier to do it all on the PI and only state the access trhough samba or sftp.

Any advice?
Thanks in advance.
Last Edit: 2 years 11 months ago by Jerome 347.
The administrator has disabled public write access.

Re: Second HDD won't mount. 2 years 11 months ago #15

  • chewitt
  • chewitt's Avatar
Yes
The administrator has disabled public write access.
  • Page:
  • 1
  • 2