NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Automount does not work after upgrade to 8.0.0

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #1

  • Khomiakov
  • Khomiakov's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Hi there,

After recent upgrade to 8.0.0 my raspberry pi 3 has stopped to mount external USB drive automatically. The device exists in the system (/dev/sdb1) but it does not mount automatically to /var/media/ExtDisk. I can mount it manually still.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #2

  • mcatto
  • mcatto's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Same problem :(
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #3

  • micke1m
  • micke1m's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Same here on a regular desktop PC, reinstalled 7.0.1.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #4

  • NickB
  • NickB's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Exact same problem here and so I tried to revert my RPi2 back to 7.0.1 but think I missed some files as on the main screen the menu options started half way down and went below the bottom of the screen (possibly a screen resolution setting) and a number of system menu options had buttons but no text - however my 2 external drives did mount. I then went back to 8.0.0 where my drives were again not mounted and tried to manually mount them but I think I've missed something in the command as I got:
OpenELEC:/var/media # cd /var/media
OpenELEC:/var/media # mkdir SAMSUNG2
OpenELEC:/var/media # mount /dev/sda1 /var/media/SAMSUNG2
mount: mounting /dev/sda1 on /var/media/SAMSUNG2 failed: Invalid argument

Any suggestions appreciated, the external drives are formatted NTFS and when I checked them via mount with my 7.0.1 install I got the following information:
/dev/sda1 on /var/media/SAMSUNG2 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
Last Edit: 7 months 1 week ago by NickB.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #5

  • jcgfs
  • jcgfs's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
NickB,

Did you try using

mount -t ntfs /dev/sda1 /var/media/SAMSUNG2
Last Edit: 7 months 1 week ago by jcgfs.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #6

  • jcgfs
  • jcgfs's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
I have the same problem after an update from 7 on a RPi2. Everything works except automount.
I can manually mount the drives but they are not shared. Any solution?
Thanks
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #7

  • NickB
  • NickB's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
I was just about to post that I'd found my mistake and it was that I needed to include "-t ntfs", thanks jcgfs.

I can now see the drives and my media plays fine.

The only small problem outstanding now is that I don't appear to be able to see the drives from my PC, previously I could see them under \\openelec, and so, for example, I could navigate to \\openelec\SAMSUNG2 and copy files over. I need to investigate this further but for now at least I can watch my media.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #8

  • NickB
  • NickB's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
jcgfs:"I can manually mount the drives but they are not shared. Any solution?" sounds like exactly the same problem I mentioned in my reply to you a few minutes ago. If I find out how to fix this I'll post it here.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #9

  • jcgfs
  • jcgfs's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
NickB wrote:
jcgfs:"I can manually mount the drives but they are not shared. Any solution?" sounds like exactly the same problem I mentioned in my reply to you a few minutes ago. If I find out how to fix this I'll post it here.

A temporary solution would be to manually edit the smb.conf file but I would prefer to have the automount working as in the previous versions so I will wait for a definitive solution.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #10

  • rnbdream
  • rnbdream's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
i have same problem

where i can find the smb.conf file?
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #11

  • jcgfs
  • jcgfs's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
rnbdream wrote:
i have same problem

where i can find the smb.conf file?

in /etc/samba
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #12

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
this issue will be fixed in 8.0.1 the next days
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #13

  • liveatul
  • liveatul's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Alter mounting manually you need to re-enable " auto-share external drives" from settings/services.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #14

  • liveatul
  • liveatul's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Alter mounting manually you need to re-enable " auto-share external drives" from settings/services.
The administrator has disabled public write access.

Automount does not work after upgrade to 8.0.0 7 months 1 week ago #15

  • liveatul
  • liveatul's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
NickB wrote:
jcgfs:"I can manually mount the drives but they are not shared. Any solution?" sounds like exactly the same problem I mentioned in my reply to you a few minutes ago. If I find out how to fix this I'll post it here.

Alter mounting manually you need to re-enable " auto-share external drives" from settings/services.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2