NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: My NAS ip address changed > can't locate MEDIA

My NAS ip address changed > can't locate MEDIA 4 months 3 days ago #1

  • tjsuominen
  • tjsuominen's Avatar
  • Offline
  • Junior Boarder
  • Posts: 30
  • Thank you received: 3
  • Karma: 0
Hi all,

I needed to to change my NAS ip address for various reasons. My NAS holds both my movies and music. After the ip change, I did followingI:

1. In .kodi/userdata modified my sources.xml file containing the new ip-addr. of the NAS
2. In .kodi/userdata modified my mediasources.xml to contain the new up-addr. of the NAS
3. Created ./kodi/userdata/advancedsettings.xml file to contain SMB substitute of new ip-addr.
4. Rebooted OpenElec.

>>

Kodi starts but still seems not locating my media sources (/ libraries).

For some reason, seems the pathsubstitution isn't working (not for me, at least). The movie metadata is all there, but when I try to play a movie, Kodi UI freezes upon trying to locate (?) the media. My advancedsettings.xml is located @ ./kodi/userdata

Anything I would need to do to the MyMusic* and MyVideos* files if I'd still wanna pursue this...

Seems my next options are:

1) revert back to the old ip address (doable, for sure) or
2) Install OE from scratch (long weekend @ some point).

Much appreciated for step by step instructions.


PS. I'm running OpenElec 6.0.3 with KODI 15.2 (yeah, I know...). After I get this up & running, will update but NEED to have this sorted out first!
The administrator has disabled public write access.