NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: HDMI - not set as primary output

HDMI - not set as primary output 2 years 2 weeks ago #1

  • Xander
  • Xander's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Using lastest 6.0.0 version, OpenELEC display is maladjusted on my LG TV connected through HDMI to my Laptop when using 1920x1080. I've attached a picture showing this.
I suspect that this happens due to HDMI1 no being selected as primary output, cause I can have a normal display after issuing
xrandr --output HDMI1 --mode 0xf1 --primary
But this solution only lasts until reboot, I guess I have to configure xorg.conf. After reboot, TV display is 1360x768.
It even works if I set 1920x1080 in Kodi settings and issue xrandr --ouput HDMI1 --primary. Then, both TV and Laptop displays are adjusted.
The TV display is moved to fit all in the screen. The laptop display, cause output is to big to fit all, moves from showing bottom right Kodi corner and a black strip at right to show top left Kodi corner.

The display on TV is ok with other resolutions, such as 1360x768, but I get some screen tearing, at least, with this one resolution.
I was able to use 1920x1080 fine with previous version 5.0.8 only configuring Kodi settings. The output would be to big to fit all in the laptop screen but was fine in the TV. I get the same situation, both in TV and laptop screen, after issuing the above xrandr command, using latest 6.0.0 version.

My laptop is one with Nvidia Optimus, bellow is lspci output.
I can't find anything useful in kodi.log. I also tried pressing laptop's fn shortcuts to switch ouput, but didn't help.

OpenELEC 5.0.8
xrandr
/usr/lib/kodi/kodi-xrandr

OpenELEC 6.0.0
xrandr
/usr/lib/kodi/kodi-xrandr
lspci



I really suspect the issue is caused by HDMI1 not being properly set as primary output.
Is someone else experiencing this issue? What is causing it? What is a solution?
The administrator has disabled public write access.

HDMI - not set as primary output 2 years 2 weeks ago #2

  • musico
  • musico's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
Hi,

I've the exact same issue with a sony vaio laptop and a LG tv.

Regards.
The administrator has disabled public write access.

HDMI - not set as primary output 2 years 1 week ago #3

  • Xander
  • Xander's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Section "Monitor"
  Identifier	"HDMI1"
  Option 	"Primary"	"yes"
  Option	"PreferredMode"	"1920x1080"
EndSection

With the above xorg.conf, display is well adjusted in LG tv, issue gone.
Save it in /storage/.config/xorg.conf and reply saying if fixed it for you, please.
The administrator has disabled public write access.
The following user(s) said Thank You: danmerks

HDMI - not set as primary output 1 year 9 months ago #4

  • Xander
  • Xander's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Update: this problem still occurs on OpenELEC 6.0.1. The Fix is same: setup xorg.conf described previously .
The administrator has disabled public write access.

HDMI - not set as primary output 1 year 9 months ago #5

  • MrVisB
  • MrVisB's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
OK. Think I have same problem. Display on laptop fine, connect HDMI then only upper left "laptop" resolution displays (max available in the GUI settings). Even if fnF4 to output only HDMI, stays the same. New to Linux entirely, but decent tech capable. Just need a walk thru to access command line, Nav to the xorg file to then examine and modify the HDMI settings as mentioned above. (BTW, is 1920x1080 the standard output for a 40in 1080p TV?)
Fresh install of current openELEC on wiped HD in 64bit HP laptop I am configuring as a dedicated HTPC. As I said, entirely new to Linux, so have to do the uphill learning curve.
Last Edit: 1 year 9 months ago by MrVisB.
The administrator has disabled public write access.

HDMI - not set as primary output 1 year 9 months ago #6

  • Xander
  • Xander's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Read the SSH commands wiki section.
The xorg.conf doesn't exist by default, you have to create it yourself.
I suppose you can also upload the xorg.conf file using Samba shares.MrVisB wrote:
(BTW, is 1920x1080 the standard output for a 40in 1080p TV?)
Yes.
The administrator has disabled public write access.

HDMI - not set as primary output 4 months 2 weeks ago #7

  • danmerks
  • danmerks's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
***After a lengthy search, this solution (#3) worked out. I placed the new xorg.conf in \\OPENELEC\Configfiles, rebooted, et voila!***

Beforehand, I messed around with other xorc.conf configurations and the randr command. Randr gave the desired result, but I couln't execute it on boot. Files likes local.rc aren't writable.

Thank you!
The administrator has disabled public write access.