NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem to start openElec

Problem to start openElec 3 months 1 week ago #1

  • mero
  • mero's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Hello,

Since openelec 8.0, xorg is configure to use amdgpu driver (i have radeon HD 4550 and i have a custom xorg.conf with driver "radeon" and it's work fine with openelec 7). But with update to 8.0 : radeon driver is not available and openelec don't start X server.

How can i configure the xorg.conf ? i try "amdgpu"... no available too...

Thanks
The administrator has disabled public write access.

Problem to start openElec 3 months 1 week ago #2

  • mero
  • mero's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
I try with a simple xorg.conf file :

Section "Device"
Identifier "AMDGPU"
Driver "modesetting"
EndSection

it's work :-D
The administrator has disabled public write access.

Problem to start openElec 3 months 1 week ago #3

  • mero
  • mero's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Well, it's work... but one time on three...

I think modules are not load on the same order...
The administrator has disabled public write access.

Problem Xorg : loading glx module 3 months 1 week ago #4

  • mero
  • mero's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
OK i found the problem, but i don't know to solve it.

My motherboard have NVIDIA chipset with graphic card (disabled) and i have a graphic card ATI (RADEON HD 4550)

At the start of openelec, xorg load module glx but sometimes i have :
[3878058.158] (II) LoadModule: "glx"
[3878058.158] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[3878058.174] (II) Module glx: vendor="NVIDIA Corporation"
[3878058.174] compiled for 4.0.2, module version = 1.0.0
[3878058.174] Module class: X.Org Server Extension
[3878058.174] (II) NVIDIA GLX Module 340.102 Mon Jan 16 12:37:38 PST 2017
[3878058.174] (II) LoadModule: "modesetting"

and other times :

[3878181.932] (II) LoadModule: "glx"
[3878181.933] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[3878181.964] (II) Module glx: vendor="X.Org Foundation"
[3878181.964] compiled for 1.19.3, module version = 1.0.0
[3878181.964] ABI class: X.Org Server Extension, version 10.0
[3878181.964] (II) LoadModule: "modesetting"

I don't want to load NVIDIA glx because i want to use my ATI graphic card. How can i do that ?
The administrator has disabled public write access.

Problem Xorg : loading glx module 3 months 1 week ago #5

  • mero
  • mero's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
well...

xorg is configured by the script /var/lib/xorg/xorg-configure and this script receive "nvidia-legacy" and not "modesetting" in my /storage/.config/xorg.conf sometimes !!! WTF ???
The administrator has disabled public write access.