NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: hifiberry Digi+ on rpi2 openelec 8.0.0 not working

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 5 months 1 week ago #1

  • zacc
  • zacc's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
hy at all...
i have tryed to instll openelec 8 on my Raspberry Pi 2.
but i can not choose the digi+ on my settings in openelec.
here my config file:
dtoverlay=hifiberry-digi
dtdebug=1


and the log



001279.585: HDMI:EDID version 1.3, 1 extensions, unknown aspect ratio
001279.649: HDMI:EDID features - videodef 0x80 !standby !suspend !active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF
001279.714: HDMI:EDID found preferred CEA detail timing format: 1920x1080p @ 50 Hz (31)
001279.758: HDMI:EDID found CEA detail timing format: 1920x1080p @ 60 Hz (16)
001279.854: HDMI:EDID standard timings block x 8: 0x0101 0101 0101 0101 0101 0101 0101 0101
001292.865: HDMI:EDID parsing v3 CEA extension 0
001292.904: HDMI:EDID monitor support - underscan IT formats:no, basic audio:yes, yuv444:yes, yuv422:yes, #native DTD:2
001292.950: HDMI:EDID found CEA detail timing format: 1920x1080i @ 50 Hz (20)
001292.990: HDMI:EDID found CEA detail timing format: 1920x1080i @ 60 Hz (5)
001293.034: HDMI:EDID found CEA detail timing format: 1280x720p @ 50 Hz (19)
001293.076: HDMI:EDID found CEA detail timing format: 1280x720p @ 60 Hz (4)
001293.113: HDMI:EDID found CEA format: code 31, 1920x1080p @ 50Hz (native)
001293.146: HDMI:EDID found CEA format: code 16, 1920x1080p @ 60Hz (native)
001293.180: HDMI:EDID found CEA format: code 20, 1920x1080i @ 50Hz
001293.213: HDMI:EDID found CEA format: code 5, 1920x1080i @ 60Hz
001293.247: HDMI:EDID found CEA format: code 32, 1920x1080p @ 24Hz
001293.280: HDMI:EDID found CEA format: code 19, 1280x720p @ 50Hz
001293.312: HDMI:EDID found CEA format: code 4, 1280x720p @ 60Hz
001293.343: HDMI:EDID found CEA format: code 18, 720x576p @ 50Hz
001293.376: HDMI:EDID found CEA format: code 3, 720x480p @ 60Hz
001293.408: HDMI:EDID found CEA format: code 17, 720x576p @ 50Hz
001293.440: HDMI:EDID found CEA format: code 2, 720x480p @ 60Hz
001293.473: HDMI:EDID found CEA format: code 22, 1440x576i @ 50Hz
001293.506: HDMI:EDID found CEA format: code 7, 1440x480i @ 60Hz
001293.540: HDMI:EDID found CEA format: code 21, 1440x576i @ 50Hz
001293.572: HDMI:EDID found CEA format: code 6, 1440x480i @ 60Hz
001293.602: HDMI:EDID found CEA format: code 1, 640x480p @ 60Hz
001293.653: HDMI:EDID found audio format 2 channels PCM, sample rate: 32|44|48 kHz, sample size: 16 bits
001293.672: HDMI:EDID found HDMI VSDB length 8
001293.697: HDMI:EDID HDMI VSDB has physical address 2.0.0.0
001293.719: HDMI:EDID HDMI VSDB supports AI:yes, dual link DVI:no
001293.750: HDMI:EDID HDMI VSDB deep colour support - 48-bit:no 36-bit:yes 30-bit:yes DC_yuv444:yes
001293.768: HDMI:EDID HDMI VSDB max TMDS clock 190 MHz
001293.794: HDMI:EDID HDMI VSDB content type support: game|cinema|photo|text
001293.826: HDMI:EDID extended data block tag 0x05 length 3 not supported
001293.865: HDMI:EDID filtering formats with pixel clock > 162 MHz or h. blanking > 1023
001294.002: HDMI:EDID preferred mode remained as CEA (31) 1920x1080p @ 50 Hz with pixel clock 148 MHz
001307.865: HDMI:Setting property pixel encoding to Default
001307.885: HDMI:Setting property pixel clock type to PAL
001307.904: HDMI:Setting property content type flag to No data
001307.924: HDMI:Setting property fuzzy format match to enabled
001316.004: gpioman: gpioman_get_pin_num: pin WL_LPO_CLK not defined
001316.027: gpioman: gpioman_get_pin_num: pin BT_ON not defined
001316.046: gpioman: gpioman_get_pin_num: pin WL_ON not defined
001514.636: hdmi: HDMI:>>>>>>>>>>>>>Rx sensed, reading EDID<<<<<<<<<<<<<
001526.690: hdmi: HDMI:EDID version 1.3, 1 extensions, unknown aspect ratio
001526.759: hdmi: HDMI:EDID features - videodef 0x80 !standby !suspend !active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF
001526.829: hdmi: HDMI:EDID found preferred CEA detail timing format: 1920x1080p @ 50 Hz (31)
001526.877: hdmi: HDMI:EDID found CEA detail timing format: 1920x1080p @ 60 Hz (16)
001526.976: hdmi: HDMI:EDID standard timings block x 8: 0x0101 0101 0101 0101 0101 0101 0101 0101
001539.991: hdmi: HDMI:EDID parsing v3 CEA extension 0
001540.033: hdmi: HDMI:EDID monitor support - underscan IT formats:no, basic audio:yes, yuv444:yes, yuv422:yes, #native DTD:2
001540.082: hdmi: HDMI:EDID found CEA detail timing format: 1920x1080i @ 50 Hz (20)
001540.126: hdmi: HDMI:EDID found CEA detail timing format: 1920x1080i @ 60 Hz (5)
001540.173: hdmi: HDMI:EDID found CEA detail timing format: 1280x720p @ 50 Hz (19)
001540.219: hdmi: HDMI:EDID found CEA detail timing format: 1280x720p @ 60 Hz (4)
001540.259: hdmi: HDMI:EDID found CEA format: code 31, 1920x1080p @ 50Hz (native)
001540.295: hdmi: HDMI:EDID found CEA format: code 16, 1920x1080p @ 60Hz (native)
001540.332: hdmi: HDMI:EDID found CEA format: code 20, 1920x1080i @ 50Hz
001540.368: hdmi: HDMI:EDID found CEA format: code 5, 1920x1080i @ 60Hz
001540.406: hdmi: HDMI:EDID found CEA format: code 32, 1920x1080p @ 24Hz
001540.442: hdmi: HDMI:EDID found CEA format: code 19, 1280x720p @ 50Hz
001540.476: hdmi: HDMI:EDID found CEA format: code 4, 1280x720p @ 60Hz
001540.511: hdmi: HDMI:EDID found CEA format: code 18, 720x576p @ 50Hz
001540.547: hdmi: HDMI:EDID found CEA format: code 3, 720x480p @ 60Hz
001540.582: hdmi: HDMI:EDID found CEA format: code 17, 720x576p @ 50Hz
001540.615: hdmi: HDMI:EDID found CEA format: code 2, 720x480p @ 60Hz
001540.652: hdmi: HDMI:EDID found CEA format: code 22, 1440x576i @ 50Hz
001540.689: hdmi: HDMI:EDID found CEA format: code 7, 1440x480i @ 60Hz
001540.725: hdmi: HDMI:EDID found CEA format: code 21, 1440x576i @ 50Hz
001540.759: hdmi: HDMI:EDID found CEA format: code 6, 1440x480i @ 60Hz
001540.793: hdmi: HDMI:EDID found CEA format: code 1, 640x480p @ 60Hz
001540.847: hdmi: HDMI:EDID found audio format 2 channels PCM, sample rate: 32|44|48 kHz, sample size: 16 bits
001540.869: hdmi: HDMI:EDID found HDMI VSDB length 8
001540.898: hdmi: HDMI:EDID HDMI VSDB has physical address 2.0.0.0
001540.922: hdmi: HDMI:EDID HDMI VSDB supports AI:yes, dual link DVI:no
001540.957: hdmi: HDMI:EDID HDMI VSDB deep colour support - 48-bit:no 36-bit:yes 30-bit:yes DC_yuv444:yes
001540.978: hdmi: HDMI:EDID HDMI VSDB max TMDS clock 190 MHz
001541.008: hdmi: HDMI:EDID HDMI VSDB content type support: game|cinema|photo|text
001541.043: hdmi: HDMI:EDID extended data block tag 0x05 length 3 not supported
001541.086: hdmi: HDMI:EDID filtering formats with pixel clock > 162 MHz or h. blanking > 1023
001541.225: hdmi: HDMI:EDID preferred mode remained as CEA (31) 1920x1080p @ 50 Hz with pixel clock 148 MHz
001541.246: hdmi: HDMI: hotplug attached with HDMI support
001541.283: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
001543.698: hdmi: HDMI: power_on to CEA mode 1080p50
001546.876: hdmi: HDMI: Action callback added to queue to happen at frame 2
001546.898: hdmi: HDMI: Action stop_3d_mode added to queue to happen at frame 2
001546.922: hdmi: HDMI: Action unmute added to queue to happen at frame 3
001607.123: *** Restart logging
001608.119: Read command line from file 'cmdline.txt'
boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 quiet
001910.249: Loading 'kernel.img' to 0x8000 size 0x4ebd48
001924.398: No kernel trailer (run mkknlimg to fix) - assuming DT-capable
001927.358: Loading 'bcm2709-rpi-2-b.dtb' to 0x4f3d48 size 0x404f
001938.857: dtdebug: delete_node(/__local_fixups__)
001946.986: dtdebug: /aliases:i2c_vc=i2c0
001952.705: dtdebug: /__symbols__:i2c_vc=i2c0
001957.425: dtdebug: /__overrides__:i2c_vc=i2c0
001969.296: dtdebug: /__overrides__:i2c_vc_baudrate=i2c0_baudrate
001974.117: dtdebug: /aliases:i2c=i2c1
001980.007: dtdebug: /__symbols__:i2c=i2c1
001984.790: dtdebug: /__overrides__:i2c=i2c1
001989.682: dtdebug: /aliases:i2c_arm=i2c1
001995.604: dtdebug: /__symbols__:i2c_arm=i2c1
002000.426: dtdebug: /__overrides__:i2c_arm=i2c1
002012.494: dtdebug: /__overrides__:i2c_baudrate=i2c1_baudrate
002024.575: dtdebug: /__overrides__:i2c_arm_baudrate=i2c1_baudrate
002024.597: dtparam: pwr_led_gpio=35
002027.979: dtdebug: Found override pwr_led_gpio
002028.023: dtdebug: override pwr_led_gpio: cell target gpios @ offset 4 (size 4)
002037.334: dtparam: uart0_clkrate=48000000
002040.776: dtdebug: /__overrides__ has no uart0_clkrate property
002040.790: Unknown dtparam 'uart0_clkrate' - ignored
002043.736: dterror: not a valid FDT - err -9
002043.746: Failed to load HAT overlay
002045.191: dtdebug: Opened overlay file 'overlays/hifiberry-digi.dtbo'
002061.030: Loaded overlay 'hifiberry-digi'
002061.084: dtdebug: Found fragment 0 (offset 36)
002063.995: dtdebug: merge_fragment(/soc/i2s@7e203000,/fragment@0/__overlay__)
002064.021: dtdebug: +prop(status)
002065.778: dtdebug: merge_fragment() end
002065.834: dtdebug: Found fragment 1 (offset 112)
002072.056: dtdebug: merge_fragment(/soc/i2c@7e804000,/fragment@1/__overlay__)
002072.084: dtdebug: +prop(#address-cells)
002073.484: dtdebug: +prop(#size-cells)
002074.891: dtdebug: +prop(status)
002079.897: dtdebug: merge_fragment(/soc/i2c@7e804000/wm8804@3b,/fragment@1/__overlay__/wm8804@3b)
002079.922: dtdebug: +prop(#sound-dai-cells)
002081.362: dtdebug: +prop(compatible)
002082.723: dtdebug: +prop(reg)
002084.122: dtdebug: +prop(PVDD-supply)
002085.923: dtdebug: +prop(DVDD-supply)
002087.742: dtdebug: +prop(status)
002089.254: dtdebug: merge_fragment() end
002089.286: dtdebug: merge_fragment() end
002089.368: dtdebug: Found fragment 2 (offset 348)
002100.231: dtdebug: merge_fragment(/soc/sound,/fragment@2/__overlay__)
002100.258: dtdebug: +prop(compatible)
002101.189: dtdebug: +prop(i2s-controller)
002102.556: dtdebug: +prop(status)
002103.491: dtdebug: merge_fragment() end
002118.172: dtdebug: /aliases:serial0=uart0
002123.143: dtdebug: /aliases:serial1=uart1
003197.134: dtparam: arm_freq=900000000
003200.429: dtdebug: Found override arm_freq
003200.479: dtdebug: override arm_freq: cell target clock-frequency @ offset 0 (size 4)
003208.732: dtdebug: override arm_freq: cell target clock-frequency @ offset 0 (size 4)
003217.106: dtdebug: override arm_freq: cell target clock-frequency @ offset 0 (size 4)
003225.525: dtdebug: override arm_freq: cell target clock-frequency @ offset 0 (size 4)
003234.040: dtparam: core_freq=250000000
003237.562: dtdebug: /__overrides__ has no core_freq property
003237.575: Unknown dtparam 'core_freq' - ignored
003237.594: dtparam: cache_line_size=64
003240.878: dtdebug: Found override cache_line_size
003240.927: dtdebug: override cache_line_size: cell target cache-line-size @ offset 0 (size 4)
003257.729: dtdebug: delete_node(/hat)
003287.138: Device tree loaded to 0x2efeba00 (size 0x4594)
003290.371: gpioman: gpioman_get_pin_num: pin SDCARD_CONTROL_POWER not defined
005144.971: vchiq_core: vchiq_init_state: slot_zero = 0xee580000, is_master = 1
005149.185: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
005154.848: TV service:host side not connected, dropping notification 0x00000002, 0x00000001, 0x0000001f
014787.910: hdmi: HDMI:Setting property pixel clock type to PAL
014788.028: hdmi: HDMI: power_on to CEA mode 1080p50
014788.084: hdmi: HDMI: Action detach added to queue to happen at frame 659
014788.108: hdmi: HDMI: Action change_mode added to queue to happen at frame 659
014788.129: hdmi: HDMI: Action attach added to queue to happen at frame 659
014788.151: hdmi: HDMI: Action start_mode added to queue to happen at frame 659
014788.174: hdmi: HDMI: Action callback added to queue to happen at frame 661
014788.198: hdmi: HDMI: Action stop_3d_mode added to queue to happen at frame 661
014788.221: hdmi: HDMI: Action unmute added to queue to happen at frame 662


after the test i go back to openelec 7.0.1 and it works perfect :(

thx for help

sry for my broken english
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 5 months 1 week ago #2

Same problem here.
With the Rpi 3B
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 5 months 4 days ago #3

  • neyoneit
  • neyoneit's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
same problem - did u manage to find fix for it ?
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 5 months 3 days ago #4

  • katzco
  • katzco's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
i have the same problem raspberry 3 and hifiberry dac+ but no sound
i can select the device in openelec 8 under audio settings but no sound
Last Edit: 5 months 3 days ago by katzco.
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 4 weeks ago #5

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #6

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
I have the same trouble
it seems that the problem comes from a conflict with Pulseaudio

on Kodi with Raspbian, it's possible to desactivate pulsaudio but on openelec the parameters file is read-only, on the /dev/loop0
so we can't modify it.

if someone has a solution ?????
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #7

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
Phil44 wrote:
I have the same trouble
it seems that the problem comes from a conflict with Pulseaudio

on Kodi with Raspbian, it's possible to desactivate pulsaudio but on openelec the parameters file is read-only, on the /dev/loop0
so we can't modify it.

if someone has a solution ?????

post your logfile zip from logfiles samba share
The administrator has disabled public write access.
The following user(s) said Thank You: Phil44

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #8

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
this is my last logfiles zip

thx for your help
Attachments:
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #9

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
on the kodi wiki, i find this information :
kodi.wiki/view/PulseAudio/HOW-TO:_Disable_PulseAudio_and_use_ALSA_(without_removing_PulseAudio)_for_Ubuntu

the solution seems to put "autospawn = no" in the file /etc/pulse/client.conf

to use hifiberry digi+, we need to access to ALSA driver
but ALSA driver is blocked by pulseaudio
we can disable pulseaudio on ubuntu installation but it's not as easy on openelec disribution because all config files are read-only.

really sorry for my poor english.....
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #10

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
Phil44 wrote:
this is my last logfiles zip

thx for your help

whats the difference you have done between this two files?

please try the following: boot your rpi, connect via ssh
then run "lsmod" without quotes, there are references to "snd_soc_hifiberry_digi, snd_soc_bcm2835_i2s and snd_soc_core"?
there are references to modules including "8804 or wm8804"? let me know or paste the output here. can you downgrad to a working 7.0 and do the same so i can compare the output?
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #11

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
log of lsmod command :

OpenELEC:~ # lsmod
Module Size Used by
8021q 17154 0
snd_soc_hifiberry_digi 3502 0
snd_soc_bcm2835_i2s 4969 0
snd_soc_core 107918 2 snd_soc_bcm2835_i2s,snd_soc_hifiberry_digi
snd_compress 8117 1 snd_soc_core
snd_pcm_dmaengine 3095 1 snd_soc_core
snd_pcm 68512 2 snd_pcm_dmaengine,snd_soc_core
bcm2835_gpiomem 2759 0
fuse 80531 1
sch_fq_codel 8397 2

it works fine on 7. i will make un SD in version 7 to get a log
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #12

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
hi
i put a new SD with an openlec 7.0.1 from scratch
first reboot, hifiberry digi+ doesn't appear in the audio menu.

shutdown
modify config.txt - i put in the command :
dtoverlay=hifiberry-digi
dtdebug=1
reboot

hifiberry digi+ appers in audio menu and sound works perfertly
i put log file in attchment

lsmod on 7.0.1
OpenELEC:~ # lsmod
Module Size Used by
8021q 16138 0
snd_soc_wm8804_i2c 1344 1
snd_soc_wm8804 6957 1 snd_soc_wm8804_i2c
snd_soc_hifiberry_digi 3331 0
regmap_i2c 2817 1 snd_soc_wm8804_i2c
snd_soc_bcm2835_i2s 5740 2
snd_soc_core 100286 3 snd_soc_wm8804,snd_soc_bcm2835_i2s,snd_soc_hifiberry_digi
snd_pcm_dmaengine 2815 1 snd_soc_core
snd_pcm 66082 3 snd_soc_wm8804,snd_soc_core,snd_pcm_dmaengine
bcm2835_gpiomem 2652 0
snd_timer 17556 1 snd_pcm
snd 40770 3 snd_soc_core,snd_timer,snd_pcm
bcm2835_wdt 2777 0

on 8.0.2, snd_soc_8804 doesn't load....

thx for your help
Attachments:
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #13

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
can you try manually on 8.0.2:
modprobe snd-soc-wm8804
modprobe snd-soc-wm8804-i2c
systemctl restart kodi
(and send the logfile again after doing this)
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #14

  • Phil44
  • Phil44's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
the log file
it doesn't work

before i tried this

cat >/storage/.config/modules-load.d/hifiberry.conf <<EOF
snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_wm8804
snd_soc_wm8804_i2c
snd_soc_hifiberry_digi
EOF

but it didn't work
Attachments:
The administrator has disabled public write access.

hifiberry Digi+ on rpi2 openelec 8.0.0 not working 4 months 3 weeks ago #15

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
if you remove this configfile and you do a modprobe manually after a restart for this wm8804 drivers you get any output in dmesg or "journalctl" output?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2