NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Problem accessing NAS samba shares

Problem accessing NAS samba shares 4 years 7 months ago #16

  • maxxx
  • maxxx's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
www.sendspace.com/file/wmdrb7

This is all logs log made this way:
- samba log level 3 set
- all old logs removed
- server and client rebooted
- password protected disk successfuly mapped using Win XP client and xbmc login / pass
- all new logs that were created attached
pass: openelec
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #17

  • maxxx
  • maxxx's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
www.sendspace.com/file/cmu2zh

the same steps done for unsuccessful OpenElec "add samba share" process
I think it may be easier for you to compare where the problem lays
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #18

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
But now you have removed the log with the openelec client, so I can't compare :P
There is lot of Authentication FAILED in those logs. Did you succeed at the first try ? it seems odd.

And I definitly think that you must remove (comment) the "username" line from your conf, it makes the server trying to authenticate as root first, and than as xbmc, and then... I really don't think you need it.

Whatever, my next question will perhaps sounds stupid but...
How did you input your password in XBMC/openelec ? using the XBMC on screen virtual keyboard, or using a real keyboard ?
If using a real keyboard, are you sure that your keyboard is correctly configured (AZERTY/QWERTY/other) so that the password you type in was the good one ? (you can test by typing your password in the username field, so that what you type won't be masked by ****).
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #19

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
Ok, didn't see your second post with the old logs...

Can you try to add :
lanman auth = yes

in your smb.conf file (in the global section), reload the samba service and try again ?
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #20

  • maxxx
  • maxxx's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
1. lanman auth added in global section (in very first line actually)
2. username = ... removed from config
3. both - server and Pi running OpenElec rebooted
4. no changes whatsoever, still keeps asking to input login/password over and over again

Regarding the other questions:
- I use a mouse to add video -> browse smb network -> select server -> select folder -> enter username and pass
- Yes, mapping the disk is successful every time at the very first time. I have to choose "map the drive using other username", because the default "guest" is displayed as default under XP.

I saw many errors as well, but I think you may be right - that's why I removed the "username =..." as you suggested. I really don't think that there is something wrong with SAMBA server (see the list of other devices using the same share flawlessly). It must be something wrong with OE. Some small error. My other NAS with password protection works ok with OE. Probably this is the reason that developers can't find the mistake, it works in most cases, but not in ALL cases.
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #21

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
Can you try to reset your password on the samba server _after_ having enabled "lanman auth = yes" ?
www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html#LANMANAUTH :
When this parameter is set to no this will also result in sambaLMPassword in Samba's passdb being blanked after the next password change. As a result of that lanman clients won't be able to authenticate, even if lanman auth is reenabled later on.
So it's possible that your passdb doesn't contain what you need until you set it again.

EDIT : Look into your samba log if you don't see an error like :
"ntlm_password_check: NO LanMan password set for user xbmc (and no NT password supplied)" now, which would confirm that.

And another question, you mentionned you had XBMC SMB shares working on other installs, but aren't they all Windows installs ?
The XBMC smbclient code does not work in the same way between Linux and Windows installs, so I would be really surprised that another XBMC/linux does not have the problem (my guess is that the problem is in XBMC, not related to OE).
Last Edit: 4 years 7 months ago by e_esprit.
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #22

  • maxxx
  • maxxx's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
Done. Same thing. Password seems to be accepted from the SAMBA server side (check_ntlm_password: guest authentication for user [] succeeded), but that's it.

Devices working with samba as it is:
This includes 3 computers (Win XP, Win 7, Ubuntu), Dreambox, two android phones, XBOX and some crappy network player.

[2013/04/14 18:29:34.835886, 3] smbd/process.c:1662(process_smb)
Transaction 0 of length 194 (0 toread)
[2013/04/14 18:29:34.836501, 3] smbd/process.c:1467(switch_message)
switch message SMBnegprot (pid 1159) conn 0x0
[2013/04/14 18:29:34.863778, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [PC NETWORK PROGRAM 1.0]
[2013/04/14 18:29:34.864290, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [MICROSOFT NETWORKS 1.03]
[2013/04/14 18:29:34.864720, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [MICROSOFT NETWORKS 3.0]
[2013/04/14 18:29:34.865142, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [LANMAN1.0]
[2013/04/14 18:29:34.865554, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [LM1.2X002]
[2013/04/14 18:29:34.865966, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [DOS LANMAN2.1]
[2013/04/14 18:29:34.866373, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [LANMAN2.1]
[2013/04/14 18:29:34.866786, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [Samba]
[2013/04/14 18:29:34.867200, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [NT LANMAN 1.0]
[2013/04/14 18:29:34.867625, 3] smbd/negprot.c:598(reply_negprot)
Requested protocol [NT LM 0.12]
[2013/04/14 18:29:34.868928, 3] smbd/negprot.c:401(reply_nt1)
not using SPNEGO
[2013/04/14 18:29:34.869356, 3] smbd/negprot.c:704(reply_negprot)
Selected protocol NT LANMAN 1.0
[2013/04/14 18:29:34.871529, 3] smbd/process.c:1662(process_smb)
Transaction 1 of length 134 (0 toread)
[2013/04/14 18:29:34.872000, 3] smbd/process.c:1467(switch_message)
switch message SMBsesssetupX (pid 1159) conn 0x0
[2013/04/14 18:29:34.872494, 3] smbd/sesssetup.c:1333(reply_sesssetup_and_X)
wct=13 flg2=0xc801
[2013/04/14 18:29:34.873060, 3] smbd/sesssetup.c:1536(reply_sesssetup_and_X)
Domain=[WORKGROUP] NativeOS=[Unix] NativeLanMan=[Samba 3.6.13] PrimaryDomain=[null]
[2013/04/14 18:29:34.873508, 3] smbd/sesssetup.c:1552(reply_sesssetup_and_X)
sesssetupX:name=[WORKGROUP]\[xbmc]@[openelec]
[2013/04/14 18:29:34.874430, 3] smbd/sesssetup.c:151(check_guest_password)
Got anonymous request
[2013/04/14 18:29:34.874944, 3] auth/auth.c:219(check_ntlm_password)
check_ntlm_password: Checking password for unmapped user []\[]@[] with the new password interface
[2013/04/14 18:29:34.875369, 3] auth/auth.c:222(check_ntlm_password)
check_ntlm_password: mapped user is: []\[]@[]
[2013/04/14 18:29:34.875927, 3] auth/auth.c:268(check_ntlm_password)
check_ntlm_password: guest authentication for user [] succeeded
[2013/04/14 18:29:34.878308, 3] smbd/server_exit.c:181(exit_server_common)
Server exit (failed to receive smb request)
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #23

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
The success here is for guest, not the xbmc user.
It doesn't seem to try to authenticate with the credentials you configured (xbmc/yourpassword). No error, but no succes neither now... That's weird.

As a workaround, you should still be able to mount your samba shares outside of XBMC directly in OE, so XBMC will then see them as local directories.
Exemple here how to do it :
wiki.openelec.tv/index.php?title=Mounting_network_shares#Example_3:
The administrator has disabled public write access.
The following user(s) said Thank You: maxxx

Problem accessing NAS samba shares 4 years 7 months ago #24

  • maxxx
  • maxxx's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 14
  • Karma: 0
Well, thanks for your help. As a workaround I just disable password protection for my media folder in my local network. I'm not happy about that, because every local user would have full R/W access to this share. I hope that some DEVELOPER would eventually fix the problem.

@chewitt would you pass the information to the proper person? e_esprit and myself spent plenty time trying to rectify this issuse and thanks that you can find a lot of useful information that would help to find the solution. Please.
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #25

  • chewitt
  • chewitt's Avatar
As I said in post #3, the SMB client is part of XBMC so the appropriate developer(s) are not in this forum. btw, there appears to be a fault on your keyboard
The administrator has disabled public write access.

Problem accessing NAS samba shares 4 years 7 months ago #26

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
Yep, it's definitly XBMC (on linux) related, not OpenElec related.
trac.xbmc.org/
The administrator has disabled public write access.

Problem accessing NAS samba shares 2 years 8 months ago #27

  • bluc
  • bluc's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
  • Karma: 0
Add another with this problem is there any workarounds?
The administrator has disabled public write access.

[Solved] Problem accessing NAS samba shares 2 years 4 months ago #28

Solved

I have been banging my head against wall over this issue for the past few hours, and I figured this would be a good place to leave my solution since I actually think this may be a problem related to OpenELEC rather than XMBC.

What I did was to turn of the Samba server that comes bundled with OpenELEC, from the OpenELEC submenu under Settings (if my memory now serves).

Also, a big thank you to everyone on the OpenELEC team for providing us with this platform, you are doing an awesome job and I do really mean that! :-)
The administrator has disabled public write access.
  • Page:
  • 1
  • 2