NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: Upgraded to 8.0.3 and lost samba workgroup

Upgraded to 8.0.3 and lost samba workgroup 4 months 3 weeks ago #1

  • dgavin
  • dgavin's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
  • Karma: 1
I upgraded raspberry pi to 8.0.3 and /etc/samba/smb.conf now has the default workgroup again. I've created the /storage/.config/smb.conf file but after several reboots the workgroup is still the default one. /run/samba/smb.conf has been updated but /etc/samba/smb.conf is unchanged. Did I miss something ?
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 4 months 3 weeks ago #2

  • sraue
  • sraue's Avatar
  • Offline
  • Developer
  • Posts: 2094
  • Thank you received: 650
  • Karma: 131
in 8.0 its /storage/.config/samba4.conf, there should also be a samba4.conf.sample file you need to use as a startpoint
The administrator has disabled public write access.
The following user(s) said Thank You: jmooremcc, dgavin

Upgraded to 8.0.3 and lost samba workgroup 4 months 3 days ago #3

  • tom2014
  • tom2014's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Has the problem gone ?

I've seen basically the same issue: after upgrade sometime problems while accessing samba workgroups - so: hard reset to default.

8.0.3 does not see _any_ smb shares at all - and from the gui it seems that while changing the WORKGROUP the gui crashes....


(donwgraded to 7.0.1 : all shares can be accessed ; upgrade to 8.0.3; hard reset; no shares; changing the WORKGROUP: GUI crashed)

//tom
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 4 months 3 days ago #4

  • dgavin
  • dgavin's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
  • Karma: 1
I gave up and reloaded 7. Too many things broke and resisted being fixed in 8 and 7 worked fine for me.
The administrator has disabled public write access.
The following user(s) said Thank You: tom2014

Upgraded to 8.0.3 and lost samba workgroup 4 months 1 day ago #5

  • chevy54
  • chevy54's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
same issue on generic builds screwed around for over an hour and it still isnt very stable
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 4 months 3 hours ago #6

  • serialne
  • serialne's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Same problem here, worked fine with ver 7, tried upgrading to Ver 8 when it came out but rolled back to 7 due to all the problems with that release. Now on 8.3 which seems better but still having the Samba shares problem. Worked around it by using IP addressing. (I noticed that Zeroconf saw the Samba shares tho). Strange.
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 4 months 1 hour ago #7

  • ednt
  • ednt's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hi,

I'm fighting with json-rpc, smb and 8.0.3

I use:
{"jsonrpc":"2.0","id":1,"method":"Player.Open","params":{"item":{"file":"smb://user:password@fs2/tv-eingang/TV-Bild.jpg"}}}
and get no answer from Kodi.

Now i tried:
curl smb://user:password@fs2/tv-eingang/TV-Bild.jpg
on the ssh console and get:
curl: (1) Protocol "smb" not supported or disabled in libcurl

Maybe that's the reason for my smb problem.

Or is something wrong with my json?
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 3 months 3 weeks ago #8

  • spunkie
  • spunkie's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Does anyone have a solution for the SMB problem.
Just upgraded yesterday, but lost the connection.
Downgraded back to 7, but lost the ability to see the menu. :blink:

I guess I need a clean install of 7 and use my backup file (thank god, I made one)

(trying to connect a Apple Time Capsule to a RaspberryPi)
Last Edit: 3 months 3 weeks ago by spunkie.
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 3 months 2 weeks ago #9

  • bitmap
  • bitmap's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 16
  • Karma: 0
I just installed the new version 8.0.3 on a brand new SD card.
Kodi can not connect to my shared folders under Windows 10.
In the meantime, I continue to use my usual SD card with openelec 7.0.1.
I hope that a solution will be found soon!
A big thank you to the Openelec team!
Raspberry Pi First-Generation single-core models (Model B / 512MB)
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 3 months 2 weeks ago #10

  • gtoons
  • gtoons's Avatar
  • Offline
  • Junior Boarder
  • Posts: 24
  • Karma: 0
Same here, upgraded my main HTPC yesterday to 8.0.3 from 7.0.1 and lost my samba workgroup - it literally stalls trying to connect. Weird it worked after install then the next day it doesn't. Updated today to 8.0.4 and still no joy. Rolling back to 7.0.1, restoring from backup.

The NUC in the bedroom runs 7.0.1 and works fine with the samba workgroup.

Look forward to a fix.
The administrator has disabled public write access.

Re:RE: Upgraded to 8.0.3 and lost samba workgroup 3 months 5 days ago #11

  • jmooremcc
  • jmooremcc's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 1
  • Karma: 0
sraue wrote:
in 8.0 its /storage/.config/samba4.conf, there should also be a samba4.conf.sample file you need to use as a startpoint
I've confirmed that @sraue is correct. I've examined the source code and found out that the configuration filename that we must use should be samba4.conf which must be based on the samba4.conf.sample. The reason this change was made was due to a security flaw in previous versions of Samba.

I too was frustrated with changes to the samba.conf not taking effect. But don't do like i did and rename your existing samba.conf to samba4.conf. Not only will it not work, but I found out the hard way that doing so will prevent you from accessing the samba server.

Once you configure the samba4.conf file, reboot and all your shares will become available.

Sent from my GT-P3113 using Tapatalk
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 2 months 3 weeks ago #12

  • spandi13
  • spandi13's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Infact you might want to take a back-up of 7.01 and install the 8.03. If the back-up contained path to Samba Shares it would even work. But establishing newer paths through Samba is out of the question.

I downloaded the 8.02 LibreElec Update Tar file and dropped into the Update Folder. Now all the Samba Shares are working and newer paths can also be established. Otherwise the "Workgroup" network is simply not seen
The administrator has disabled public write access.

Upgraded to 8.0.3 and lost samba workgroup 2 months 1 week ago #13

  • bitmap
  • bitmap's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 16
  • Karma: 0
Hello,
I am stuck in 7.01 the shares windows 10 are not seen by openelec 8.0.4
it is boring

I have installed LibreElec 8.0.2 on a new SD , i have entered manually the SMB share paths and this works.
Raspberry Pi First-Generation single-core models (Model B / 512MB)
Last Edit: 1 month 3 weeks ago by bitmap.
The administrator has disabled public write access.