NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

Welcome, Guest
Username: Password: Remember me

TOPIC: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares?

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #181

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
silvine wrote:
cobels wrote:

I am looking forward to an end-user friendly solution to mounting NAS drives as I use sab-suite all the time.

It's not not a true "user friendly solution" but NFS share is OK on my NAS, from my AD10 + Openelec eden, using this NFS mounting process in /Configfiles/autostart.sh file, described in my post :
openelec.tv/forum/76-network-filesystems/11391-netmountconf-is-ditched-in-new-eden-how-to-set-sambacifs-shares?limit=20&start=160#23155

+

Set insecure flag for NFS on my NAS

+

Create NFS link on Openelec device :
Menu VIDEO / Add Video source / Browse / Network File System (NFS)
-> nfs://192.168.1.100/raid0/data/VIDEOS/
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
Last Edit: 5 years 9 months ago by Jean-Max.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #182

  • Tiwas
  • Tiwas's Avatar
  • Offline
  • Junior Boarder
  • Posts: 65
  • Thank you received: 1
  • Karma: 0
So...What's the current status on this? I've kind of messed up a little while trying to solve this through mounting using the gui and netmount.conf .

I'm using SMB, the share is /video/Serier and /video/Filmer . This is what happens when trying to mount through SSH to find the correct command.
root ~ # mount -t cifs //192.168.1.15/video ~/videos
mount: mounting //192.168.1.15/video on /storage/videos failed: Invalid argument
root ~ # mount -t smbfs //192.168.1.15/video/Serier/ ~/videos
mount: mounting //192.168.1.15/video/Serier/ on /storage/videos failed: No such device

So...kind of stumped here :S Anyone able to lend a hand? I'm using the most current version of Eden, and the plan is to move couch potato and sick beard onto the media center...

Cheers!
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #183

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
Tiwas wrote:
...netmount.conf
I'm using SMB, the share is /video/Serier and /video/Filmer . This is what happens when trying to mount...
For SMB shares, no need to mount anything..

Example to add a SMB VIDEO share :

Videos
Add Videos
Browse
Choose: Windows network (SMB)
WORKGROUP
Choose: <distant SMB server name> (ex: NAS name)
Choose: <distant shared folder name>
OK
Appears auto created link like : smb://<SMB server name>/<Distant shared folder name>
Enter name for media source
OK

Note:
To accelerate SMB share, replace in SMB link syntax :
smb://<SMB server name>/...
by
smb://<SMB server IP>/...
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
Last Edit: 5 years 9 months ago by Jean-Max.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #184

Jean-Max,

this works fine until you want to use sabnzbd or sickbeard... both of them require you to use mounts.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #185

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
Tiwas wrote:
I'm using SMB, the share is /video/Serier and /video/Filmer . This is what happens when trying to mount through SSH to find the correct command.
root ~ # mount -t cifs //192.168.1.15/video ~/videos
mount: mounting //192.168.1.15/video on /storage/videos failed: Invalid argument

Try :

mount -t cifs //192.168.1.15/video ~/videos -o if you call command from inside /configfiles/autostart.sh file

mount -t cifs //192.168.1.15/video /videos -o if you call command from root

Make sure folder names are exact (case sensitive)
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #186

  • Tiwas
  • Tiwas's Avatar
  • Offline
  • Junior Boarder
  • Posts: 65
  • Thank you received: 1
  • Karma: 0
Jean-Max wrote:
mount -t cifs //192.168.1.15/video /videos -o

Tried this, but got the following error "There are filesystem-specific -o flags."
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #187

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
Tiwas wrote:
Tried this, but got the following error "There are filesystem-specific -o flags."
Excuse my error : -o if for options (ex: '-o guest' to bypass security)

I don't understand why classic command gives error :
mount -t cifs //server's IP/shared folder /path_to/mount client folder
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
Last Edit: 5 years 9 months ago by Jean-Max.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #188

  • Tiwas
  • Tiwas's Avatar
  • Offline
  • Junior Boarder
  • Posts: 65
  • Thank you received: 1
  • Karma: 0
Thanks - that worked! I'll change to use autostart.sh instead of netmounts.conf in anticipation of the new version :)

Do I need to set any flags on autostart.sh ? 755?
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #189

  • Tiwas
  • Tiwas's Avatar
  • Offline
  • Junior Boarder
  • Posts: 65
  • Thank you received: 1
  • Karma: 0
Jean-Max wrote:
Tiwas wrote:
Tried this, but got the following error "There are filesystem-specific -o flags."
Excuse my error : -o if for options (ex: '-o guest' to bypass security)

I don't understand why classic command gives error :
mount -t cifs //server's IP/shared folder /path_to/mount client folder

Sorry for bugging you...I upgraded to the latest nightly to get support for autostart.sh

It's now in /storage/.config . So, it doesn't mount on bootup, and if I try to execute the file I'm getting an error again (on something which worked before upgrading)...

This is what I'm getting:
root ~/.config # ./autostart.sh
mount: mounting //192.168.1.15/video on /storage/videos failed: Invalid argument

I'd really appreciate the help, as now sick beard and coach potato will no longer work...Cheers!
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #190

  • Tiwas
  • Tiwas's Avatar
  • Offline
  • Junior Boarder
  • Posts: 65
  • Thank you received: 1
  • Karma: 0
Thanks! That saved my hide :)
DejaVu wrote:
Had to return to this because I do not like getting beaten.

I am using Windows 7 x64 as my server as it's on 24/7 anyway. I tried HaneWin NFS Server, but nearly ended up bald trying to set it up correctly. Back to CIFS I came.

Here is MY ./autostart.sh file in the config directly. This add my share no problem from a Windows PC standard share.
#!/bin/sh

#kip for a bit. Don't interrupt oE while it's busy.
sleep 15;

#make the folder(s) the mount(s) will live in - vanishes on reboot for me.
mkdir /media/TVShows1

#mount the folder into the folder created above (doh!)
mount -t cifs -o username=user,password=pass,rw  //192.168.0.3/TVShows1 /media/TVShows1;

#Put the kettle on then watch stuff on my HTPC mounted from my Windows PC.

REMEMBER to make autostart.sh executable. Pointless exercise if you dont!!
root ~ # chmod +x /storage/.config/autostart.sh
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 9 months ago #191

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
DejaVu wrote:
H... ./autostart.sh file in the config directly.
...
#make the folder(s) the mount(s) will live in - vanishes on reboot for me.
mkdir /media/TVShows1
...
It's curious that for NFS share I successfully built in autostart.sh file, it's not necessary to re-create at each boot, the local mount-link folder ..
Why this difference between SMB and NFS ?

Thanks :)
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
The administrator has disabled public write access.

Help - I've read the thread yet still can't get this to work ! 5 years 8 months ago #192

  • dberliner
  • dberliner's Avatar
I'm sorry , can anyone help me with this?

I've read the entire thread, yet still unable to make this work .

I'm using OpenELEC-Ultra.x86_64-devel-20120309130449-r10068 (latest of now).

My server is Windows 7 Enterprise 64 bit.

I can mount manually

I created autostart.sh in .config

However, whenever I put in this command:

#! /bin/sh
(sleep 30; \
mount -t cifs //192.168.1.100/NewsBin /storage/NewsBin -o username=myusername,password=mypassword \
)&

I get this:

-sh: ./autostart.sh: not found

If I just babble something in there, just plain text, I can read the file!

Anyone know why that is??
Attachments:
Last Edit: 5 years 8 months ago by dberliner. Reason: Had some progress.
The administrator has disabled public write access.

Re: Help - I've read the thread yet still can't get this to work ! 5 years 8 months ago #193

  • Jean-Max
  • Jean-Max's Avatar
  • Offline
  • Expert Boarder
  • Posts: 329
  • Thank you received: 7
  • Karma: 1
Hello,

After creating autostart.sh and before rebooting, had-you made the file executable ?


root ~ # chmod +x /storage/.config/autostart.sh
Jean-Max
- OpenELEC-Nvidia_Legacy.x86_64-6.0.3 on ZBOX HD-ID11
- OpenELEC-Generic.x86_64-6.0.3 on ZBOX Nano AD10
- OpenELEC_RPI2 arm 6.03 on Raspberry 3 B
- KODI Windows 16.0 on 4 PC W7 W8
- KODI Android X86 16.0 on Galaxy Tab 3 10.1
- Data on NAS Thecus N7700Pro (7*2To, Raid 5)
- HDHomerun
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 8 months ago #194

  • ilya
  • ilya's Avatar
  • Offline
  • Junior Boarder
  • Posts: 71
  • Thank you received: 7
  • Karma: 4
To answer for dberliner, who has now fixed his problem:
The issue was with his samba share authentication - Requiring a username without a password.

Changing the format of DejaVu's mount command to:
mount -t cifs -o username=user,rw //192.168.0.3/TVShows1 /media/TVShows1

..worked without issue
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 8 months ago #195

  • dberliner
  • dberliner's Avatar
Yes it worked without issue. But I seem to be losing the mount after a long period of inactivity or after I rebooted the system.. Don't know why. I then can regain it by making autostart.sh executable again using the chmod +x /storage/.config/autostart.sh command.

I wonder why I need to use that command over and over again... any thoughts? I'm not tampering with the file!
Last Edit: 5 years 8 months ago by dberliner.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 8 months ago #196

  • RvdH
  • RvdH's Avatar
Just a heads-up: when mounting via autostart.sh mount to the root of the NAS/Share.

My netmount.conf looked like:
cifs | //192.168.0.192/Volume_1/media/tv shows | /storage/nastv
cifs | //192.168.0.192/Volume_1/media/music | /storage/nasmusic
cifs | //192.168.0.192/Volume_1/media/movie | /storage/nasmovies
cifs | //192.168.0.192/Volume_1/media/downloads | /storage/nasdownloads

I now have the autostart.sh looks like:
#! /bin/sh
(sleep 30; \
mount -t cifs //192.168.0.192/Volume_1 /storage/nas -o username=guest
)&

In Sabnzbd and Sickbeard/Coutchpotato I just set the paths to /storage/nas/media/movie instead of /storage/nasmovies. Works like a charm :)
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 7 months ago #197

  • tenzion
  • tenzion's Avatar
  • Offline
  • Junior Boarder
  • Posts: 20
  • Karma: 0
I am trying to the same with AFP to my Time Capsule, but it won't quite work.

Doing this:

! /bin/sh
(sleep 30; \
mount -t afp://user:password@server_ip/Data/folder /storage/TimeCapsule
)&

results in this error:

root ~ # mount: can't find /storage/TimeCapsule in /etc/fstab

?? What seems to be the problem??
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 7 months ago #198

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
I never used afp, but the mount syntax is :
mount -t <type> <source/device> <mount_point>

So in your case, you're missing the type option, I guess it should be something like :
! /bin/sh
(sleep 30; \
mount -t afp afp://user:password@server_ip/Data/folder /storage/TimeCapsule
)&
Last Edit: 5 years 7 months ago by e_esprit.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 7 months ago #199

  • tenzion
  • tenzion's Avatar
  • Offline
  • Junior Boarder
  • Posts: 20
  • Karma: 0
Yes, that solved the fstab part.

But doing this again with the correct protocol added, results in:
root ~ # mount: mounting afp://user:password@ip_address/Data/tv on /storage/tv failed: No such device

[1]+  Done(255)               ( sleep 15; mount -t afp afp://user:password@ip_address/Data/tv on /storage/tv )
root ~ #

What to make of this? The "tv" folder exists both on the openelec host and on my TimeCapsule.
Last Edit: 5 years 7 months ago by tenzion.
The administrator has disabled public write access.

Re: Netmount.conf is ditched in new EDEN, how to set samba/cifs shares? 5 years 7 months ago #200

  • e_esprit
  • e_esprit's Avatar
  • Offline
  • Senior Boarder
  • Posts: 180
  • Thank you received: 9
  • Karma: 3
I am not really sure that the mount command in OpenELEC (which used busybox) does support the AFP protocol.

Can't you use the AFP support in XBMC ?
Last Edit: 5 years 7 months ago by e_esprit.
The administrator has disabled public write access.