NOTE! This site uses cookies and similar technologies.

If you not change browser settings, you agree to it.

I understand

The OpenELEC 7.0 Beta 1 (internal version 6.95.1) release has been published. Users running older OpenELEC releases will need to manually update to this Beta. If you would like to update from an older OpenELEC release please read update instructions/advice on the Wiki before updating. Manual update files can be obtained from the downloads page.

OpenELEC 7.0 Beta 1 is a feature release. The main changes are:

  • Platform changes:
    • New Platform WeTek Core supported with a own Build
      WeTek Core is the best Android TV box you can have to watch IPTV, Movies and TV Shows while you relax on your sofa.
      With an AMLogic S812-H, 2GHz Quad-core processor, 4K Support and 8-bit H265, this box will give you all entertainment you are looking for.
    • Merged Nvidia_Legacy build to Generic build.
      Users who used the Nvidia_Legacy build now have to use our Generic build.
  • Core OS updates and changes (old version in brackets):
    • ALSA updated to 1.1.0 (1.0.29)
    • Binutils updated to 2.26 (2.25)
    • GCC updated to 5.3 (4.9)
    • glibc updated to 2.23 (2.22)
    • Python updated to 2.7.11 (2.7.3)
    • LLVM updated to 2.8 (2.6)
    • Linux kernel updated to 4.4 (4.1)
    • Mesa updated to 11.2rc (11.0)
    • ffmpeg updated to 2.8 (2.6)
    • libva updated to 1.7 (1.6)
    • connman updated to 1.31 (1.23)
    • libnfs updated to 1.10 (1.9)
    • libressl updated to 2.2 (2.1)
    • systemd updated to 229 (219)
    • xorg-server updated to 1.18 (1.17)
  • Driver and firmware updates and changes:
    • updated WLAN drivers and firmware
    • added new AMDGPU driver for new AMD Graphic cards
    • updated Intel Graphic driver
    • merged Nvidia with Nvidia legacy driver to support old and new Graphic cards with one build.
  • Kodi updates and changes (old version in brackets)
    • Kodi updated to 16.1rc (15)
  • New features
    • Bluetooth Audio support (see below)
    • OpenVPN reincluded

Enable and use Bluetooth Audio support

  • Enable Bluetooth support via OpenELECs settings addon
  • connect your Bluetooth Audio hardware via OpenELEC settings addon
  • change your Audio device to PULSE: Default, Bluetooth Audio (PULSEAUDIO)
  • disable passthrough in Kodis Audio settings

 

Kodi 16 support

OpenELEC 7.0 release contain a Kodi major version bump. If you are updating from OpenELEC 6.0 or earlier we strongly recommend you perform a full backup before performing a manual update. If you experience issues please perform a soft-reset to clear OpenELEC and Kodi settings.

If you want to support us, you can buy your own RaspberryPi-2 at ThePiHut by using this link.
ThePiHut Logo

banner openelec

WeTek OpenELEC Box - LIMITED EDITION
Designed from the inside to the outside

Thinking about all OpenELEC community, we have been working with our sponsor partner WeTek on a TV box dedicated to Kodi. Let us present you the WeTek OpenELEC model, a special edition, with pre-installed OpenELEC that combines DVB and multimedia contents.

Receiving IPTV channels is good, but broadcasting DVB channels with only one box, is great. WeTek OpenELEC is available with 3 different tuners, depending on your location and signal type (satellite, cable, terrestrial) you may opt for different tuners (DVB-S2, DVB-C/T/T2 and ATSC).

You may use a HDMI or an AV cable to connect the box, this guarantee that it can be used not only with modern TV but also with older one. This is the easiest way to enjoy Kodi environment on your TV.

This new device is already available on our website and includes 24 months guarantee and free express delivery. This is a limited edition reserved for OpenELEC fans, so access our OpenELEC webshop and don't wait to get your own.

Help Supporting OpenELEC

If you would like to contribute to the OpenELEC project, there are lots of ways you can help. We are always looking for people to help with documentation, testing and reporting bugs. If you enjoy using OpenELEC and would like to make a donation to support the project, you can do this using PayPal. Donating is easy and takes only a few minutes, and you do not need a PayPal account to make a donation. We can also accept donations by other means (bitcoin, flattr, etc…). You can find out more about donating here.

Flattr this

Bitcoin Address:
157WZSD1bDyJNWVQrKqaf5oF343q9Dscuf

Note: You do not need a PayPal account to make a PayPal donation.

 

How To Upgrade To OpenELEC 7.0 beta 1 (6.95.1) Release

If you are going to update from one of our older releases, we STRONGLY advise that you make a backup of your XBMC data and do a manual update . You can use our OpenELEC Settings addon if you are using OpenELEC-3.2 or later to backup your data. For more details, please visit http://wiki.openelec.tv/index.php?title=Updating_OpenELEC.

OpenELEC.tv is hosted and sponsored by

Testing and Reporting

There has been many months of development and testing in the run-up to this releases, but like any major update there are a lot of changes. Unfortunately, we are unable to test every scenario on all hardware, so it’s possible you might pick up on an issue we may have missed (this is why we do beta tests). We would like anyone brave enough to test this release and report issues that they find either with OpenELEC or Kodi.

Thank You!

We would like to thank our users, team members and partners for testing, reporting and fixing issues, creating how-to documents, developing new features, and their donations of hardware and funds to the project. We appreciate your continued support, without it we would not be able to continue.

Questions & Feedback

If you have any questions about OpenELEC, sponsoring the project, or think you might be able to offer another service that will be useful to us, then please drop me an email at This email address is being protected from spambots. You need JavaScript enabled to view it.. There is always someone that is able to answer your questions in the #openelec irc on freenode.

You can find the new release of OpenELEC 7.0 beta 1 (6.95.1) on the downloads page


Posted: 6 months 1 week ago by saharmali #163642
saharmali's Avatar
hoo, great! Just upgraded.

VDR VNSI Client addon made problems after the first boot with the new version, where many addons were updated. I saw errors in the frontend and this in the log:
Posted: 7 months 1 week ago by AndyD #162372
AndyD's Avatar
Hi,
I'm interested in how the audio over LAN will look? I've been looking for a way to stream audio from Kodi on my Pi3 in party mode out the the LAN like an internet radio station. Will this do it?
Thanks,
Andy.
Posted: 7 months 2 weeks ago by LordVader7 #162135
LordVader7's Avatar
Hello I have Bluetooth speakers to Raspberry pi 3 and works OK apart from it will not remember pairing on cold boot or restart.So i have to keep pairing & connecting
on every startup.Am i doing something wrong?
Apart from that no issues on beta but reconnecting on boot
Thanks
Posted: 7 months 3 weeks ago by nickr #161558
nickr's Avatar
escalade wrote:
On Windows you can set Kodi to use an external player for video files, and then use Stereoscopic Player for 3D MVC. The downside being the player is not integrated in Kodi, so remote control will not work (at least not out of the box I think). Oh and running Windows is a downside in itself :P
Kodi plays MVC on Windows if you use a recent afedchin test build - see the kodi forums for more info. Anyway, we are OT now as this is an OE forum, not a windows forum, I was just setting the record straight.
Posted: 7 months 3 weeks ago by mata7 #161512
mata7's Avatar
yeah i dislike windows completely, i will stay with my openelec htpc and hope someting better come for us intel users on openelec
Posted: 7 months 3 weeks ago by escalade #161390
escalade's Avatar
On Windows you can set Kodi to use an external player for video files, and then use Stereoscopic Player for 3D MVC. The downside being the player is not integrated in Kodi, so remote control will not work (at least not out of the box I think). Oh and running Windows is a downside in itself :P
Posted: 7 months 3 weeks ago by mata7 #161386
mata7's Avatar
nickr wrote:
escalade wrote:
It's only for the Pi, I'm afraid. Reason being that the Pi does it in hardware, and there is no open source decoder available at the moment. I don't know if there's any hope for an Intel solution any time soon, especially with 3D becoming less popular.
There is an intel solution if you use windows.

and what is that solution? thanks
Posted: 7 months 3 weeks ago by mata7 #161385
mata7's Avatar
escalade wrote:
It's only for the Pi, I'm afraid. Reason being that the Pi does it in hardware, and there is no open source decoder available at the moment. I don't know if there's any hope for an Intel solution any time soon, especially with 3D becoming less popular.

thanks for you help
Posted: 7 months 4 weeks ago by monteiro #161383
monteiro's Avatar
monteiro wrote:
Getting authentication failed from stalker server after update from 6.03 to 7. Hardware is Asus chrome

Sent from my SM-G900W8 using Tapatalk
Went back to 6.03 and stalker server is working again. On the other hand openelec 7 was rebooting by itself, also noticed a big lag and freezing issues when navigating through the system. I'm wondering if a fresh install of beta 7 would correct some of the issues

Sent from my SM-G900W8 using Tapatalk
Posted: 7 months 4 weeks ago by nickr #161370
nickr's Avatar
escalade wrote:
It's only for the Pi, I'm afraid. Reason being that the Pi does it in hardware, and there is no open source decoder available at the moment. I don't know if there's any hope for an Intel solution any time soon, especially with 3D becoming less popular.
There is an intel solution if you use windows.
Posted: 7 months 4 weeks ago by Sprocket #161359
Sprocket's Avatar
For anybody else using PUTTY and seeing SSH errors or just plain no response

*** UPDATE YOUR PUTTY TO LATEST VERSION ***

I was using 0.63
It's been fine for everything else but not for OpenELEC for some reason.
This older PUTTY sometimes just does nothing with OE 6.03 and gives SSH errors with 6.95.1

I just updated PUTTY to version 0.67 and that works just fine.
Posted: 7 months 4 weeks ago by escalade #161334
escalade's Avatar
It's only for the Pi, I'm afraid. Reason being that the Pi does it in hardware, and there is no open source decoder available at the moment. I don't know if there's any hope for an Intel solution any time soon, especially with 3D becoming less popular.
Posted: 7 months 4 weeks ago by mata7 #161331
mata7's Avatar
No worries, I've been anxiously awaiting this feature so I've been experimenting with different Kodi trees and patches. From what I have found out, the OE7 beta uses the Kodi tree from popcornmix' "jarvis_rbp_backports" branch, which has been patched for the Raspberry Pi. It does have some level of support, as you can see the extra 3D MVC options in the menus, but it does not work yet. I've tried adding the missing patches for libbluray and ffmpeg, but that wasn't enough. There's been two updates to the Kodi tree in the OE7 git since I tried last, so it might be worth a shot to try the latest. I believe you would also need the patches mentioned. I've moved on to OE8/Kodi17 which has it working, so not going to bother any more with it.

do you know if the 3d support will be only for PI or will be also for generic openelec? like i have a intel htpc wiht generic openelec installed
Posted: 7 months 4 weeks ago by monteiro #161307
monteiro's Avatar
Getting authentication failed from stalker server after update from 6.03 to 7. Hardware is Asus chrome

Sent from my SM-G900W8 using Tapatalk
Posted: 7 months 4 weeks ago by Sprocket #161301
Sprocket's Avatar
I'm seeing exactly the same SSH/network issue reported above by andy-b

This is with 6.95.1 on a Pi 3.

I can connect OK using putty 0.63 on the Windows 7 x64 PC sat right next to the pi (on same network switch).
But if I try to connect from any other PC on the network of from my laptop (connected to the same subnet over wifi) then I get the SSH2_MSG_UNIMPLEMENTED response and putty disconnects. Strange!

On a brighter note, WiFi Tethering on Pi3 works great in this update.
Previously I had 6.03 and found that tethering did not work on Pi3, always failing in authentication.
The same 6.03 image worked fine on a Pi2 with a USB wiFi dongle.
Posted: 7 months 4 weeks ago by martyz #161289
martyz's Avatar
martyz wrote:
Hi guys,
found weird behaviour, 6.95.1 version on Wetek Play openelec edition:

- when I set Czech language, after reboot it is reset to English, Australia region
- while entering master pin code, no number keys are accepted, just arrows and ok button, standard wetek openelec remote... Before I was using OE 6.0.2 version

sorry if redundant, I scrolled thru all 7 pages but nothing similar found

no hints pls? replicated on two wetek play oe edition boxes, one clean install, one updated...
Posted: 7 months 4 weeks ago by escalade #161283
escalade's Avatar
nickr wrote:
Please excuse me, I think I have misread (or mis remembered) something I read. You do seem to be right, so again my apologies.

No worries, I've been anxiously awaiting this feature so I've been experimenting with different Kodi trees and patches. From what I have found out, the OE7 beta uses the Kodi tree from popcornmix' "jarvis_rbp_backports" branch, which has been patched for the Raspberry Pi. It does have some level of support, as you can see the extra 3D MVC options in the menus, but it does not work yet. I've tried adding the missing patches for libbluray and ffmpeg, but that wasn't enough. There's been two updates to the Kodi tree in the OE7 git since I tried last, so it might be worth a shot to try the latest. I believe you would also need the patches mentioned. I've moved on to OE8/Kodi17 which has it working, so not going to bother any more with it.
Posted: 7 months 4 weeks ago by rexgremlin #161282
rexgremlin's Avatar
nickr: extended the partition using gparted as you suggested(to 256MB) . Indeed it helped and upgrade passed. Now I have Kodi 16.1 running on my Xtreamer. I should have noticed that the new tar files were a little bit more bigger...

Thank you very much for your kind assistance!!
Posted: 8 months 3 hours ago by nickr #161269
nickr's Avatar
rexgremlin wrote:
Sorry nickr my fault - I put the .tar file to \\openelec\update network share folder. Anyway after booting xtreamer recognized it unpacked it ...and then ended with that error I described. I have plenty space - 500GB disc in my Xtreamer.

Yes but the boot partiton may be too small, OE have recently increased the size, but the update can't increase the /boot partition size. You can do it by booting, eg, a ubuntu live USB and using gparted to increase the boot partition on your hard drive.

Or you could do a fresh install, but you will lose everything in /storage. There are utilities to backup kodi/OE data, but any media etc on your disk will need to be shifted off and retransfered back.
Posted: 8 months 3 hours ago by nickr #161268
nickr's Avatar
escalade wrote:
nickr wrote:
3d iso / mvc works with 7.0 beta AFAIK.

Why do you keep repeating this when in fact it doesn't? I've referenced to missing patches above, and you now have two confirmed reports here from RPi owners. It works in OE8 master branch and in Milhouse builds, not in OE7 beta. Period.
Please excuse me, I think I have misread (or mis remembered) something I read. You do seem to be right, so again my apologies.
Posted: 8 months 3 hours ago by rexgremlin #161267
rexgremlin's Avatar
Sorry nickr my fault - I put the .tar file to \\openelec\update network share folder. Anyway after booting xtreamer recognized it unpacked it ...and then ended with that error I described. I have plenty space - 500GB disc in my Xtreamer.
Posted: 8 months 3 hours ago by nickr #161266
nickr's Avatar
It's /storage/.update not /storage/upload

But you probably need to expand your boot partition using gparted or similar
Posted: 8 months 9 hours ago by rexgremlin #161254
rexgremlin's Avatar
Hello,
I just tried to update using OpenELEC-Generic.x86_64-6.95.1.tar
After rebooting the system found the tar file, gave me 2 times "OK" for MD5 check and then I got the following error:
Checking size: FAILED
size check failed. normal startup in 30sec...


I have downloaded the tar file 3 times to be sure - it is not corrupted.

Machine: Xtreamer Ultra running Openelec 6.0.3 (Kodi 15.2 Isengard).

Do you know whether Xtreamer Ultra users are allowed to install ? Maybe full image install would pass ? Thank you for you help !!
Posted: 8 months 13 hours ago by escalade #161250
escalade's Avatar
nickr wrote:
3d iso / mvc works with 7.0 beta AFAIK.

Why do you keep repeating this when in fact it doesn't? I've referenced to missing patches above, and you now have two confirmed reports here from RPi owners. It works in OE8 master branch and in Milhouse builds, not in OE7 beta. Period.
Posted: 8 months 15 hours ago by mata7 #161245
mata7's Avatar
nickr wrote:
3d iso / mvc works with 7.0 beta AFAIK.

on my system dont work, how did you make work on yours?